KTK 2.09.31 Test Server - Please report any bug you find

  • Sorry for the offtopic, but since it was discussed, I have a small question to ask you... I've come up with just now:
    But when you unfortunately lose the prestige, and after u reset prestige, lose anyway "Challenges" (those who are in "Rank & Challenges") or not depends on the prestige?
    Simply because I have almost completed all, I miss just a few that seem to be bugged*!


    *: I know I'm interested about the little details ... I'm obsessive! :D I wanted to make a screenshot of this, but it would take a long time and then my game is in Italian! :/



    In case you loose your rank you will not loose your challenges, setting or w.e. is saved in the mpdata.
    As long as you keep using the same profile it's only your rank which is lost (and can be recovered by an admin (correct rank and prestige level))


    Just checked the scripts of the final killcam and there already are dvars to define the length:
    set scr_killcam_time 10 // length from killcam start to killcam end
    set scr_killcam_posttime 2 // time after player death that killcam continues for

  • Should be fixed, i never came across this.


    It's kinda rare. Happened again yesterday on our public server on 2.09.30.



    All tests i ran with hardpoints were fine, make sure you don't have an airstrike/helicopter chosen on a map which has no airsupport set in config ;)


    Damn I'm stupid, it was disabled by default on shipment in the cfg... So that's why they weren't appearing lol. Though I think I really didn't get the RC-XD after the first round. Anyway, I'll test again :P



    I'm currently working on the scripts to disable hardpoints separately for each map.

    :thumbup:



    Just checked the scripts of the final killcam and there already are dvars to define the length:
    set scr_killcam_time 10 // length from killcam start to killcam end
    set scr_killcam_posttime 2 // time after player death that killcam continues for


    As far as I know scr_killcam_time defines the time of the "regular" killcam, not the final killcam. Or at least on our server, these times are different, so if they should be the same, there's a bug ^^
    Btw, is it possible to see the killcam when you get killed as a guard by an assassin? For now we can only see the kc as assassin killed by a guard.



    Edit: I edited the config so now Javelin can be shot 3 times, and weaponbox price is 2 for guards and 1 for assassins :P Thanks for the dvars Viking :P

    __________________________________________S_____I_____G_____N_____A_____T_____U_____R_____E__________________________________________

    Any problem with a 3xP' server (server down, download loop,...)? - Feel free to mention it in the shoutbox so an admin can take care of it.
    ______________________________________________________________________________


    3xP' TS3 IP: ts.3xP-Clan.com | Click here to directly join it.
    ______________________________________




    Edited once, last by UFaced ().

  • I just played with Kurosaki on the Test server, and some weird stuff happened ^^


    1) You see the guy in white above his RC-XD when you are in fullbright -> 130144604-4.jpg
    Also at this point in the game, I was king, and Kurosaki wasn't able to see me. I was in front of him but apparently I was invisible for him O.o He also wasn't hearing me when I was shooting, but he saw the clays I planted.


    2) Final killcams are really weird. They are either shown from a very weird angle, or the king is invisible in it (no matter fullbright or not fullbright). I think there were some "normal" killcams, but I'm not sure, didn't kill the king a lot.
    Videos:
    CoD4 KTK .31 final killcam invisible king - Xfire Video
    CoD4 KTK .31 final killcam weird point of view - Xfire Video
    CoD4 KTK .31 final killcam invisible king n°2 - Xfire Video


    It may have something to do with the bots though. At some point while playing, bots disconnected, and it said the king had left, though I was the king during that round... So that was really weird. The bots are not "regular" bots I think, Duffman made a script to change them. Maybe @mirko911 can tell us more about this ^^



    PS: I checked again for the hardpoints. I think I didn't get RC-XD because I was using the switch command to put myself back in the guard team. If king kills me, looks like everything works fine. I enabled airsupport for shipment and now I get all hardpoints ^^

    __________________________________________S_____I_____G_____N_____A_____T_____U_____R_____E__________________________________________

    Any problem with a 3xP' server (server down, download loop,...)? - Feel free to mention it in the shoutbox so an admin can take care of it.
    ______________________________________________________________________________


    3xP' TS3 IP: ts.3xP-Clan.com | Click here to directly join it.
    ______________________________________




  • The JA and NEIN "translate" was for other peoples who are not interested in german x)


    Yes, these are all from the current Version of our Testserver, which I had on the older Version too. As I said, only used 1 Profile.


    Even when stuck Nade had a further travel time, you heard this annoying scratch / high pitched noice.


    I would like to see if someone can confirm this with the Options, at least it doesn't work for me :/


    This was from the old Update, happened a lot to me ^^ Not sure how it's now, need more people to Test it.


    sometimes the guards dont change to assassin.

  • I guess no defuse is not very good for the game. Makes rounds much faster.


    The defuse feature was made by Duffman and added to the mod, so it only exists on 3xP'. As the test server uses "clean" files from Viking, the defuse feature just doesn't exist in it. We'll try to implement it when we update the mod on the public server.


    For now, I reduced a bit the damage dealt by the explosion so the king won't die in one shot (should take effect next map).



    Edit: Another bug which just happened on .30, and has been existing for a long time: Sometimes when you throw a knife, it somehow thouches the target twice in a row very quickly, and so inflicts twice the dmg. So it happens only on king and terminator since guards die in 1 hit ^^ I guess the bug still happens in .31 since I hadn't reported it before, and it's not in the changelog for .31.

    __________________________________________S_____I_____G_____N_____A_____T_____U_____R_____E__________________________________________

    Any problem with a 3xP' server (server down, download loop,...)? - Feel free to mention it in the shoutbox so an admin can take care of it.
    ______________________________________________________________________________


    3xP' TS3 IP: ts.3xP-Clan.com | Click here to directly join it.
    ______________________________________




    Edited once, last by UFaced ().

  • Soooooo.


    1. Didn't get any Killstreaks. Tested with and without Bots. Only Assassins get M21. King and Guards -> No Killstreaks.


    2. Javelin ammo counter is 0, but still have unlimited ammo. Works perfect against Heli (1 shot). This was the Heli which comes when the King is alone.
    Got the Javelin from the Weapon Box and didn't loose it after I died. In the next round, Javelin was gone. <- Bots and no Bots


    3. One player was invinsible in Killcams, but in game we saw him. At the end of the Map, he couldn't vote.
    After a few seconds (every round), Server said: Player Wolgang changed his name to <- After "to" was no name. He was the invinsible guy.


    4. This happened 1 time so far. Was King, after one minute or so, it said: The King has left the Game and the round ended. Was still in game and no disconnects. <- With Bots


    5. We were 3 normal Players and 20 Bots (stress test). I've got kicked, message: "Server disconnect". I wanted to reconnect and saw the Server. It said 32 / 38 Players Online.
    3 normal players and 20 Bots.


    Hope this helps somehow. ^^



    EDIT:
    Played now my 5th or 6th round, never got any Killstreaks. Now I was King and did a few kills. I got the Killstreaks of the Guards.
    3. Rc Car
    4. Poison
    5. Carepackage.
    BUT now my Killcam don't work. I didn't changed any settings. Before this round, my Killcam worked.


    EDIT 2:
    New map and Killcam works again o.O
    So, Killcam works without a problem now. Don't know what happened.

  • @HD I think several of those bugs may come from the bots.


    1. What map did you play on? For example airsupport is disabled on lolzor (and poolday as well I think).


    2. Are you sure it was unlimited? Did you shoot only once or more than 3 times? Maybe it's not written how many shots are left so you thought it was unlimited, but maybe you actually had only 3 shots?


    3. May be because of bots.


    4. Pretty sure that's coz of bots. Same thing happened to me, at the moment when some bots disconnected.


    5. Even when bots disappear at the end of a round, they're still on the server even if they're nowhere visible. They automatically disconnect after a while (they're visible through xfire I think though).



    About the killstreaks, maybe you used the switch command? After you use it to become guard again, it seems you don't get the killstreaks. From what I've experienced.



    I think we should test without bots cause they seem to cause a lot of weird issues.
    The problems with killcams etc, that I showed in the videos, may come from them as well I think.


    I'll add a command on the public ktk server so that people will be able to join directly the server by writing it.
    But first I want to test more maps to see which ones don't work anymore, and adjust the map rotation with only small/medium maps so it's easier to test with only a few players.

    __________________________________________S_____I_____G_____N_____A_____T_____U_____R_____E__________________________________________

    Any problem with a 3xP' server (server down, download loop,...)? - Feel free to mention it in the shoutbox so an admin can take care of it.
    ______________________________________________________________________________


    3xP' TS3 IP: ts.3xP-Clan.com | Click here to directly join it.
    ______________________________________




  • My cod4 crashed when we changed maps @ testserver. We played shipment then voted backlot and cod4 crashed for all of us I guess cuz other players didn't rejoin. And now the server is back on shipment again. We can't test (other maps) when it crashes every time.

  • Ah ok UFaced. So 95% is cause of the Bots? :P


    1. It was Shipment. Everything works there.
    2. I did 3 Shots indeed. First two missing cause I was behind a Container to net get killed from the Heli ^^ Didn't needed more shots, so I don't know.


    More players would be good.


  • Another "bug" ist that you can have unlimited weapons, when you buy some from the box.


    I don't think that's really a problem ^^ And anyway wiht the normal weapon box price, people buy 1 or 2 weapons max at a time.


    tripwires for assassins didnt work yesterday when i played
    would be nice if they did.


    I think you need to be a lot more precise, otherwise Viking will never be able to fix anything ^^
    What do you mean by "tripwires didn't work"? You couldn't plant them? You could plant them and see them but they weren't exploding? You could plant them but then you couldn't see them and they weren't exploding? Or any other details that could help understanding where the bug comes from.
    Btw, I think that if you die after planting a tripwire, it will disappear. You have to stay alive from the time you planted it to the time somone walks over it for it to work.

    __________________________________________S_____I_____G_____N_____A_____T_____U_____R_____E__________________________________________

    Any problem with a 3xP' server (server down, download loop,...)? - Feel free to mention it in the shoutbox so an admin can take care of it.
    ______________________________________________________________________________


    3xP' TS3 IP: ts.3xP-Clan.com | Click here to directly join it.
    ______________________________________




  • in weapon box javelin has no ammo(im not sure if its suposed to be like that or what ?)
    if you are only player in game you cant goof around (you are like frozzen and cant move until few players are in game and the game starts)
    and i got my hardpoints just rcxd but once ond then 2 maps nothing i dont know whats the problem (is it me or what?)

  • in weapon box javelin has no ammo(im not sure if its suposed to be like that or what ?)
    if you are only player in game you cant goof around (you are like frozzen and cant move until few players are in game and the game starts)
    and i got my hardpoints just rcxd but once ond then 2 maps nothing i dont know whats the problem (is it me or what?)


    Actually, Javelin does have ammo but Its doesn't show it.. Maybe try shooting..


  • It's kinda rare. Happened again yesterday on our public server on 2.09.30.



    As far as I know scr_killcam_time defines the time of the "regular" killcam, not the final killcam. Or at least on our server, these times are different, so if they should be the same, there's a bug
    Btw, is it possible to see the killcam when you get killed as a guard by an assassin? For now we can only see the kc as assassin killed by a guard.


    1. Can you tell me which map was played and which was voted?
    Also could you check the log, maybe it's because a wrong mapname is given back from the vote.


    2. the finalkillcam uses the same dvars as the normal killcam because the scripts are basically the same.
    Killcams when getting killed as a guard were disabled because they have fucked up the spawnsystem.




    Another bug which just happened on .30, and has been existing for a long time: Sometimes when you throw a knife, it somehow thouches the target twice in a row very quickly, and so inflicts twice the dmg. So it happens only on king and terminator since guards die in 1 hit I guess the bug still happens in .31 since I hadn't reported it before, and it's not in the changelog for .31.


    Gonna have to check that, never noticed that while playing (tbh i never had an eye on it ^^)




    1. You won't get a killstreak if they are disabled in the server config. (for certain maps)
    But to be sure i'll take a look in the code.
    2. Javelin counter is always 0 because i'm giving the ammo to the player when he found a target, otherwise he can shoot without having a target.
    After 3 fired shots (no death or ammo pickup between) you can only aim but not fire the javelin.
    3. Only thing which could cause that (at least the only one i can think of) is that he died while he had no model attached, were you able to shoot him?
    4. Definitely caused by the bots
    5. Dunno, i guess the bots, but i need the logs for that.


    Test the maps local on your computer please, i don't think it's a good idea to crash the server every now and then ;)


    edit:
    1. I was throwing some knives now and i did never inflict damage twice.
    Do you also throw two knives when it happens (ammo reduced by two)?
    What's the damage you have set for the throwing knives?
    Maybe it hits the player a second time on its way to the ground.


    2. Tripwire was fine for me, i killed the king a few times with it.


    3. White players when fullbright is a bug in the engine, nothing i can do about it.
    It's because i have given the players in hardpoints (rc-xd, ac130 etc.) an invisible model to fix the head/helmet server crashes.
    Fullbright detects the texture and makes it white :/


    edit 2:
    Just added the dvars to define which weapons the assassins get from the box, and the dvars to disable the hardpoints separately on each map
    Both things will come with the next mod.ff. (when depends on how much you find in the current mod ^^)